Michigan Reefers banner
1 - 8 of 8 Posts

·
Registered
Joined
·
500 Posts
Discussion Starter · #1 ·
I have a Euro Reef protein skimmer rated for up to 150 g tanks. I have a Rio 2100 hooked up to it which is 600+ gph at zero. I have no bubbles or foam in the skimmer. The water inside of the skimmer does not reach the lock collar on the skimmer. Not sure how to get it to foam. There is an air tube that comes off of the long vent tube but it looks like it just goes down into the water. I am not sure how to get this to work. There is water going through it. The pump is running. But no foam. Nothing going up past the lock collar on the skimmer. Any tips?
 

·
Registered
Joined
·
1,154 Posts
It's been a long time since I've used a Euro Reef skimmer. But from what you're describing, the air tube should connect to a nipple on the inlet of the pump. Make sure there are no obstructions or clogging. Even when not making bubbles, the water inside the skimmer should NOT be up to the collar. If you're able to post a picture, that would help diagnose the problem.
 

·
Registered
Joined
·
500 Posts
Discussion Starter · #3 ·
Yes i need a venturi tube on my pump. Pump doesn't have one. I will have to try to make one. Its a Rio
 

·
Registered
Joined
·
500 Posts
Discussion Starter · #4 · (Edited)
It's been a long time since I've used a Euro Reef skimmer. But from what you're describing, the air tube should connect to a nipple on the inlet of the pump. Make sure there are no obstructions or clogging. Even when not making bubbles, the water inside the skimmer should NOT be up to the collar. If you're able to post a picture, that would help diagnose the problem.


Hi. I was able to secure the venturi port from my broken pump to my new pump. Instant foam. It did not climb to the collector. Not to the collar yet. Is that ok? 6-7" of foam. well short of the collector. Will it climb? Thanks.
 

·
Registered
Joined
·
500 Posts
Discussion Starter · #7 · (Edited)
Sorry did not mean to duplicate posts.
Foam is working. Now I have a micro bubble issue. I have read some posts where the skimmer has to get a slime coat built up. I did clean it with vinegar before using as it was really dirty. They are getting into the aquarium. I read to just let it run and get the slime coat. The bubbles will correct I read. Hope thats true. Skimmer might be too big for sump. It barely fits.
 

·
Registered
Joined
·
181 Posts
You could put a 90 degree elbow on the end of the output. Maybe try facing up or down to resolve the issue.
 
1 - 8 of 8 Posts
Top